Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Engine cutting out

View previous topic View next topic Go down 
AuthorMessage
Clockman
Not so new now
Not so new now


Number of posts : 38
Registration date : 2007-09-13

PostSubject: Engine cutting out   Thu Oct 07, 2010 6:55 pm

Hi, all, after 3 years of trouble free running my 3lt turbo suddenly cut out today. No warning lights or check engine before stop. Symptoms are,after stopping & switching off,wait then switch on , dash lights normal but rapid clicking from the injector pump, when this clicking stops the van will run normally for a mile or two then stop suddenly. wait a few minutes,starts instantly runs perfectly . No smoke or other symptoms. Could the fuel cut off solenioid be intermittently faulty? Got home in 2 mile stages, removed & drained the fuel filter via the drain tap, few specks of dirt nothing much ,no water in fuel sample,checked the electrical plugs on the pump, all seemed ok. Parked in the drive, the engine starts instantly, runs 10 minutes then cuts out. Repeats the above. I had run unusually low on fuel just before the above events. Any help much appreciated. Bc.
Back to top Go down
View user profile
mr freeze
Been here a while
Been here a while


Number of posts : 148
Home City : Sydney South
Model and year : 99 SC 4WD 1KZ-TE
Registration date : 2008-07-14

PostSubject: Re: Engine cutting out   Fri Oct 08, 2010 11:28 am

Hi when it stops do you have to prime the fuel pump to get it going again or it just starts again straight away. , did you keep pushing the primer pump on the fuel filter to see if it will keep running. Could be a bit of air trapped in the lines. If you ran low on fuel could be air in lines.
I never let mine get below 1/4 tank because fuel keeps the pump cool. Expensive little buggers if you need it reco'ed


The only thing it can be on the diesel engine is fuel problem.
I would replace fuel filter and eliminate things one by one.
there is also a fine mesh filter in the pump it's self ,apparently a special tool is needed to get it out.
Too fine to clean and normally replaced with new one the diesel man told me once.

Good luck , let us know how you go
Back to top Go down
View user profile
Clockman
Not so new now
Not so new now


Number of posts : 38
Registration date : 2007-09-13

PostSubject: Re: Engine cutting out   Fri Oct 08, 2010 2:00 pm

Hi. Thanks for your response. I did not need to prime to get restarted, nor did pumping prevent the cut out,I used the primer pump to draw a fuel sample and refill the filter.A pattern emerged, sit for a few mins, drive on for a mile or two. Almost as if some component was cooling down. Engine not overheating nor has ever done so. On diesels I have had in the past, any fuel blockage usually resulted in much reduced speed rather than the sudden cut out in this one. I agree on your point re fuel being the main issue. Has anyone a diagram of this pump? Interesting your info on the cooling aspect of the fuel. I had run a few miles beyond the warning light coming on . I am going to try running on a separate can of fuel piped to the filter inlet. The filter seems OK as hand priming produces a gush of fuel on each stroke. The difficulty is establishing if the pump is gone for sure, rather than some sensor. Also taking off any fault codes as listed by another member on here. Bc.
Back to top Go down
View user profile
mr freeze
Been here a while
Been here a while


Number of posts : 148
Home City : Sydney South
Model and year : 99 SC 4WD 1KZ-TE
Registration date : 2008-07-14

PostSubject: Re: Engine cutting out   Sat Oct 09, 2010 11:18 am

True, I had a prado with same engine and I run crap fuel in it for a while and filter got fully cloged up one day .
Car ran on idle ok but no acceleration at all, but did not cut out .
If your runs ok for 10 minutes and then stops suddenly i would rule out pump problems, otherwise it would run poorly all the time.
Check all vacuum hoses and air filter is clean fuel filter is clean .
Dont you hate it when they play up
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: Engine cutting out   Sat Oct 09, 2010 12:40 pm

Check all electrical connections including the ECU.
Back to top Go down
View user profile
AussieQ
Hiace Master
Hiace Master
avatar

Number of posts : 884
Age : 71
Home City : Hervey Bay Qld
Model and year : 1994 sc
Registration date : 2008-08-15

PostSubject: Re: Engine cutting out   Sat Oct 09, 2010 7:45 pm

If not the pump check the air filter. Hate intermittent faults .....
Back to top Go down
View user profile
Clockman
Not so new now
Not so new now


Number of posts : 38
Registration date : 2007-09-13

PostSubject: Re: Engine cutting out   Mon Oct 11, 2010 5:38 pm

The fault cleared for no apparent reason and it is now running normally. Each time it started it would run for longer spells before cutting out. The clicking noise stopped. The point was reached where after two hours it was still running fine. I checked for fault codes via the plug low down on the nearside footwell. Nothing showing , test mode OK as well. Road test today with no problems. All a bit odd. Must be due to running very low on fuel but why so long to clear is a mystery. Thanks to Aussie Q for the link to the engine manual, this is full of info, particularly on the diagnostics system and codes etc. well worth a read through.
Back to top Go down
View user profile
Elusive
New Member
New Member
avatar

Number of posts : 15
Home City : Tauranga, New Zealand
Model and year : 1994 Supercustom, Lowered on 18" Lenso Mags, 5% Rear Tints 35% Front tints.
Registration date : 2011-02-27

PostSubject: Re: Engine cutting out   Sun Aug 12, 2012 1:31 pm

A bit late to bring up this forum, But so future readers can see.
There is a very very common fault in the first board inside the ECU, there are two capacitors on the back of this board which "leak". There in a guy in Katikati New Zealand which fixes them for a very good price.

It can cause issues from "engine cutting out while driving" to "Only runs until the engine is warm, then cuts off". Another tell-tail sign, is the injector pump makes a clicking noise when you try start the van.

The ECU can be found in the passengers side B pillar behind the plastic cover in-front of the sliding door, (in most 93-96 Super Customs with the 1KZTE motor).

Hope this helps someone in the future.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Engine cutting out   

Back to top Go down
 
Engine cutting out
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Cutting Edge
» [Engine Remake][EN][RU] Free Heroes 2
» how to register google search engine for phpBB3?
» Search engine not responding with any results
» Channel 4 Thursday 1st April Lost Abroad - The Parents Story

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Mechanical Matters :: GREASE MONKEY !!! (sorry couldnt resist its a BF2142 thing)-
Jump to: