Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 2.8L Engine Problem

View previous topic View next topic Go down 
AuthorMessage
Merlin_



Number of posts : 15
Home City : Nelson BC
Model and year : 92 Hiace 4x4 Diesel Cruising Cabin
99 Tercel ce *mint*
00 Tacoma *loved and now lost, sold to buy my van!*
Registration date : 2012-11-26

PostSubject: 2.8L Engine Problem   Mon Dec 31, 2012 4:10 am

Something is wrong with te engine in my 92 2.8 diesel. While driving it suddenly got noticibly louder, knocking and stutters and lurches and is sort of sluggish. It still starts and runs cool and no warning lights come on, I dont think it overheated. There may be oil in the coolant however it was dark and I was not able to get a good look.

Recently it has been very cold, -20s and had to start in these conditions. Also I added generous amounts of diesel stabiliizer/ conditioner to a full tank. While driving the oil fill cap has come off and oil sprays onto the engine, could this be caused by coolant getting into the oil, ie blown head gasket?

I have been driving up to 140 on the highway which never seemed to be a problem. I dont know if any of these things could have played a role. Right now the van is parked until I return from winter break.

Does this sound like a blown head gasket/ cracked head?
Back to top Go down
View user profile
Clive



Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: 2.8L Engine Problem   Wed Jan 02, 2013 8:01 am

I'd guess at a fuelling problem. Try running direct from a fuel can to the pump bypass the filter and see if that is any different.

Does not sound like a head problem - that is more difficult to start and overheating but once started run fine until it overheats.
Back to top Go down
View user profile
Merlin_



Number of posts : 15
Home City : Nelson BC
Model and year : 92 Hiace 4x4 Diesel Cruising Cabin
99 Tercel ce *mint*
00 Tacoma *loved and now lost, sold to buy my van!*
Registration date : 2012-11-26

PostSubject: Re: 2.8L Engine Problem   Tue Jan 15, 2013 1:33 am

Never got to checking fuel system. I took it to a local garage and there seemed to be pressure coming from the bottom of the engine, explaining why the oil fill cap kept coming off. We pulled off the little 's' shaped hose from the intake manifold and there was no vacume coming from that port at all. Mechanic was unfamiliar with this type of engine but said it was ok to drive, it would just be spitting out oil. Might be PCV valve or something frozen up becasue of all the cold weather. I thried thawing out in a heated parking garage, but it quit after about 10 minutes of driving. It really heasitated and sounded much louder than usual, and suddenly just quit. I mean like really quit.
Back to top Go down
View user profile
MaXiLeeCH



Number of posts : 63
Age : 58
Home City : Innisfail QLD Australia
Model and year : 1985 Maxda T3500 Parkway Motorhome
(I upgraded from my 1994 LH125 Hiace Commuter!)

Registration date : 2012-04-30

PostSubject: Re: 2.8L Engine Problem   Sun Jan 20, 2013 5:44 am

Sounds to me like it's terminal.
I think that the engine has possibly broken one or more piston rings or piston top lands, allowing the blow by that blew off the oil cap.
Now it has seized due to the broken rings or lands galling the bore I'd say.
It's not that uncommon with the 3L (2.8 litre) engines.
(Particularly if they are subjected to high rpm's for some time. At 140KMH the engine is bloody near redline in most Hiaces and earlier SC's and it should never go anywhere near that speed)


Jeff C.

Back to top Go down
View user profile
Sponsored content




PostSubject: Re: 2.8L Engine Problem   Today at 1:53 pm

Back to top Go down
 
2.8L Engine Problem
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Search engine problem
» Apple IOS8 problem
» SCM Music Player Problem
» Webmail problem
» Image hosting problem with Servimg

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Mechanical Matters :: GREASE MONKEY !!! (sorry couldnt resist its a BF2142 thing) :: Members guides to fixing problems :: Members guides to fixing problems-
Jump to: