Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Problem with brakes

View previous topic View next topic Go down 
AuthorMessage
Harptree
New Member
New Member


Number of posts : 4
Home City : Bristol
Registration date : 2015-07-07

PostSubject: Problem with brakes   Tue 7 Jul 2015 - 21:30

Hi All. Just bought a 1993 Hiace Super Custom converted to a camper van. Loving it. A Japanese import so I'm nervous about spares and does anyone know if a workshop manual is available?
Have a worrying problem with the brakes. Every now and then the pedal goes flat to the floor. It sorts itself out and is not losing fluid. Anyone got any ideas?
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: Problem with brakes   Thu 9 Jul 2015 - 20:27

Worn mater cylinder, worn servo or sticking brake - all of which need looking at even though the bus is stopping ok!
Maybe worth a bleed through and see what new fluid does first?
Back to top Go down
View user profile
Harptree
New Member
New Member


Number of posts : 4
Home City : Bristol
Registration date : 2015-07-07

PostSubject: Re: Problem with brakes   Sun 12 Jul 2015 - 18:18

Hi Clive

Yep, the master cylinder seems to be top of the list of possible causes. It is at a garage at present which clams to be able to get parts and know the vehicle. I warned them about needing to remove the dash and they said they knew and were relaxed. I see you are Bristol based, this garage is in Hengrove. I'll let you know how I get on.
I did replace the fluid and bleed the brakes. Good for 1000mls then the problem returned.
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: Problem with brakes   Mon 13 Jul 2015 - 20:49

Parts easy to get, getting to it is the problem, Hope thw bill is small
Back to top Go down
View user profile
Harptree
New Member
New Member


Number of posts : 4
Home City : Bristol
Registration date : 2015-07-07

PostSubject: Re: Problem with brakes   Sat 25 Jul 2015 - 9:46

Total of 350 plus VAT for part and fitting. Brakes feel OK, I'm off to Cornwall so that will be a good test. They seemed relaxed about removing the dash. I did have to take out the radio and reconnect the aerial but that was simple.
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: Problem with brakes   Sun 26 Jul 2015 - 19:23

Well if you come back on brakes solved!
Back to top Go down
View user profile
Harptree
New Member
New Member


Number of posts : 4
Home City : Bristol
Registration date : 2015-07-07

PostSubject: Re: Problem with brakes   Wed 5 Aug 2015 - 19:31

I'm back. The brakes feel fine. Off to Ireland later in the month so an even bigger test.
I do have a problem that I will probably do a separate post for. The conversion has a three person bench seat that can face either forward or back and has a hinge mechanism that allows it to fold flat to be part of the bed. This mechanism has broke so I'm looking for new mechanism or seats from a scrap vehicle. No luck so far.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Problem with brakes   

Back to top Go down
 
Problem with brakes
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» SCM Music Player Problem
» Webmail problem
» Image hosting problem with Servimg
» This forum brakes your rules: Illicit contents, Hateful or abusive content, Defamatory content and / or affecting ...
» Strange problem with HTML page...javascripts doesnt seem to load...

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Mechanical Matters :: GREASE MONKEY !!! (sorry couldnt resist its a BF2142 thing) :: Members guides to fixing problems :: Members guides to fixing problems-
Jump to: