Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 engine cutting to limp home mode

View previous topic View next topic Go down 
AuthorMessage
kerrylfleigh
New Member
New Member


Number of posts : 6
Home City : Geelong
Registration date : 2013-07-01

PostSubject: engine cutting to limp home mode    Tue Jul 12, 2016 3:35 am

Hi I'm new to  this so hope this message ends up in right place etc... Am seeking some advice as my eva reliable dear SC 2000 KZH100 auto 3L Deisel has encountered it's first problem. It cuts to limp mode at random but at first would work ok if i turned motor on and off. Now it's more frequent and pretty much flips straight back to limp mode. I had the engine scanned and two error codes came up - P1121 - fault in throttle position sensor and P1122 fault in pedal position sensor....
I don't have the repair manual either and would much appreciate if anyone could forward one to me - thx I love you
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: engine cutting to limp home mode    Tue Jul 12, 2016 8:36 pm

Have you changed the fuel filter recently?
Back to top Go down
View user profile
kerrylfleigh
New Member
New Member


Number of posts : 6
Home City : Geelong
Registration date : 2013-07-01

PostSubject: Re: engine cutting to limp home mode    Fri Jul 15, 2016 2:44 am

Clive wrote:
Have you changed the fuel filter recently?

Hi Clive - yes I just had it serviced and this has started happening since... Apparently was very dirty..
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: engine cutting to limp home mode    Wed Jul 20, 2016 8:29 pm

Right I suspect there is an air leak try tightening the filter or even take it off and clean the mating surface.
Did you service it or garage - if garage take it back and get them to do it.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: engine cutting to limp home mode    

Back to top Go down
 
engine cutting to limp home mode
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Q.O.R. of Canada - Boer War Welcome Home Medal
» Home alone...Leicester Mercury 23 July 2011
» Breaking News: 4-Year-Old Boy Stabbed To Death At SE London Family Home
» British dad currently in Zambia trying to get his two boys home. HELP NEEDED URGENTLY!!!!!
» Adopted newborn coming home in about a week

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Mechanical Matters :: GREASE MONKEY !!! (sorry couldnt resist its a BF2142 thing)-
Jump to: