Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Middle moon roof and tach issues

View previous topic View next topic Go down 
AuthorMessage
Danthevanman
New Member
New Member
avatar

Number of posts : 10
Home City : Melbourne
Model and year : 1996 Hiace super custom living saloon ex 3.0lt
Registration date : 2016-07-09

PostSubject: Middle moon roof and tach issues   Wed Aug 17, 2016 12:03 am

So I've had my 96 SC for a month now and it's awesome. The only issues
I have now are the tach only works sometimes after a long drive (45 min)
Or so and the middle moon roof started working again then stopped! I can
Hear the relay clicking but no movement in the roof.
So I want these 2 things to work all the time, please help!
Back to top Go down
View user profile
Hiace4wd
Hiace Master
Hiace Master
avatar

Number of posts : 462
Home City : Netherlands
Model and year : 1994 Toyota Hiace 4x4 DIY camper
Registration date : 2016-02-01

PostSubject: Re: Middle moon roof and tach issues   Wed Aug 17, 2016 10:34 am

The tach is a digital tach?
Anyway, it sounds there is a bad electrical connection somewhere, that might only get some good connection when it is heated up (due to expansion of metal or so). But that's just guessing.

About your sunroof, did the sunroof make a normal sound when it worked?

Anyway, you could measure if the Relay is applying 12 volt to the sunroof motor, using a multimeter. And also check if there is no (or little) resistance through the relay. And if no fuse has been blown.
It would probably be easy to replace the relay, even with a universal one although it might be of different shape.
If all is looking well for the relay, the motor is going to need a replacement.
But there are also companies who can refurbish any electric motor, if you cannot find replacement.
Back to top Go down
View user profile
GPW
Hiace Master
Hiace Master
avatar

Number of posts : 449
Home City : Cambridge, UK
Model and year : Model: KD-KZH100G-MRPGT
Year: 1996
Colour: 4K1
Trim: FN42

Registration date : 2016-07-16

PostSubject: Re: Middle moon roof and tach issues   Wed Aug 17, 2016 10:59 pm

The tach is fairly easy to get at, facia off, 4 screws and the meter comes out. Agree with Hiace4wd's diagnosis, some wire wiggling around the back of the meter may narrow it down.

Hiace4wd wrote:

About your sunroof, did the sunroof make a normal sound when it worked?

Anyway, you could measure if the Relay is applying 12 volt to the sunroof motor, using a multimeter. And also check if there is no (or little) resistance through the relay. And if no fuse has been blown.
It would probably be easy to replace the relay, even with a universal one although it might be of different shape.
If all is looking well for the relay, the motor is going to need a replacement.
But there are also companies who can refurbish any electric motor, if you cannot find replacement.

I may have a similar issue with mine - although I haven't really had a chance to test it properly yet. However casually measuring the relay and motor assumes access, and access is a tricky thing!

Basically you have to remove the front headlining, which on the SC is held in at a number of points. You will need a decent PH3 screwdriver to undo the rear-view-mirror screws (they are _tight_) and some others. Then you need a decent trim removal plier to separate the rear headlining (which is plugged into the front one just behind the join and really needs to be removed first...). Then it's off with the hand-holds, trims, vents etc, then there are lugs behind the front sunroof, and the sunroof trims.

Then on the SC there is the RHS seat belt trim panel next to the drivers seat that's locked in by the side trim, although it can be manipulated. Then on the passenger side front door shut you need to remove the panel over the ECU (which needs a slight cut at the bottom to save having to remove the passenger-seat-bonnet frame), to release the top seatbelt trim panel.

Then, and only then, when the headlining panel is out, can you access the blue moon-roof controller box and motor.
After that you have to get to the PCB, which on mine didn't slide out at all, I had to hacksaw a slot in line with the PCB on one side to loosen it's grip on the PCB enough to get it out so I could see it.

That's as far as I've got, I have yet to replace the meter in the dash on mine - out for wire tracing the reverse signal and to fit a MPH scale (9.99 on eBay) so not much functions now.

BTW I'd highly recommend a battery switch like this: http://www.ebay.co.uk/itm/262564578167 so you can mess with the van in safety and casually switch it on and off when you are working on it.
Back to top Go down
View user profile
Danthevanman
New Member
New Member
avatar

Number of posts : 10
Home City : Melbourne
Model and year : 1996 Hiace super custom living saloon ex 3.0lt
Registration date : 2016-07-09

PostSubject: Re: Middle moon roof and tach issues   Thu Aug 18, 2016 2:49 am

Sunroof sounded fine when it worked briefly.
Now just clicking from the blue box which I've had
Out and it looked fine. No burned wires or burned
Smell. It's gotta be the motor I think now.
The dash is the standard kind not digital. The pick
Up is deep in the fuel pump but I'm sure it's the gauge
It's self,or a bad wire somewhere.
Back to top Go down
View user profile
GPW
Hiace Master
Hiace Master
avatar

Number of posts : 449
Home City : Cambridge, UK
Model and year : Model: KD-KZH100G-MRPGT
Year: 1996
Colour: 4K1
Trim: FN42

Registration date : 2016-07-16

PostSubject: Re: Middle moon roof and tach issues   Fri Aug 19, 2016 7:08 pm

I have the same issue with my moon roof, just clicked, no movement, no burned out tracks. So I took the motor out of the roof (2 easy bolts and one for a small ratchet 10mm spanner) and tried it on its own.

The motor works fine now, as do the relays etc.

So for me it's the roof having got too stiff for the motor to turn, so I'm wondering how to get to the bits I need to clean and lube, but it's all closed up.

I think I'll have to take the rear headlining off now for sure, and perhaps unbolt the entire moonroof assembly from the van to fix, but I'm open to suggestions!

Any ideas?
Back to top Go down
View user profile
Danthevanman
New Member
New Member
avatar

Number of posts : 10
Home City : Melbourne
Model and year : 1996 Hiace super custom living saloon ex 3.0lt
Registration date : 2016-07-09

PostSubject: Re: Middle moon roof and tach issues   Sat Aug 20, 2016 12:34 am

Sounds like that might be the case. I have a feeling
Chassis flexing might have something to do with it or
The motors just don't have enough grunt to shift
Such a big roof. What side is the motor on?
Back to top Go down
View user profile
GPW
Hiace Master
Hiace Master
avatar

Number of posts : 449
Home City : Cambridge, UK
Model and year : Model: KD-KZH100G-MRPGT
Year: 1996
Colour: 4K1
Trim: FN42

Registration date : 2016-07-16

PostSubject: Re: Middle moon roof and tach issues   Sat Aug 20, 2016 12:51 am

The motor is in the middle at the front of the moon roof.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Middle moon roof and tach issues   

Back to top Go down
 
Middle moon roof and tach issues
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» #1375 Chatbox issues
» Lowering Roof onto bedding
» [Only Topic] Notifications, Loading, Chatbox, Servimg and Tagging Issues
» Cali Roof Hood
» only-topic-forumotion-server-issues-outage

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Electrical :: Sparky Lives Ere-
Jump to: