Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Power Steering issues

View previous topic View next topic Go down 
AuthorMessage
zoochy
Been here a while
Been here a while
avatar

Number of posts : 148
Home City : Tropical Canada
Model and year : LH107G 1991
Registration date : 2007-01-21

PostSubject: Power Steering issues   Sat May 30, 2009 9:51 am

My power steering is starting to act up. Occasionally my steering gets really stiff then suddenly it will work fine again. Any advise on how to figure out what is wrong?

I’m guessing that it’s the power steering pump failing or a oil valve that is jamming??? I just don’t know where or how to go about troubleshooting this.

Cheers.
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: Power Steering issues   Sat May 30, 2009 12:11 pm

Drain and refill the fluid as a first step, Dextron II or III.
Back to top Go down
View user profile
chrisandhiace
Hiace Master
Hiace Master


Number of posts : 502
Age : 55
Home City : Preston
Model and year : LH 107 4wd 1992
Registration date : 2008-11-18

PostSubject: Re: Power Steering issues   Sat May 30, 2009 7:50 pm

Check the 'trachoid pump'....where the speedo cable goes into side of gear box.
It can dump atf on the ground.... or into the transfer box when it fails.
The tell tail sign is atf being pumped onto your left foot from behind the dash...gets sucked up the speedo cable.
It may not be your problem...but be aware thats its only a matter of time (mines a 92)
Step one...keep an eye on your atf fluid level!...+ Carry a spare bottle until resolved.
Back to top Go down
View user profile
zoochy
Been here a while
Been here a while
avatar

Number of posts : 148
Home City : Tropical Canada
Model and year : LH107G 1991
Registration date : 2007-01-21

PostSubject: Re: Power Steering issues   Sat May 30, 2009 11:10 pm

Just crawled out from underneath my van...

Nothing leaking.

I found a small bend in one of the metal tubes that goes from the trochoid pump back to the transmission (rock must of hit it). I straightened it as best as I could. I doubt that was the issue though as my steering stiffness happens regardless of speed or gear.

I’d like to replace the power steering fluid as Clive suggested but I can’t seem to find any sort of drain plug except for what looks like a really big hex (about 22mm) on the bottom of the Trochoid pump. If this is the drain plug (Clive?) then I’ll go out and find a bolt to fit in there so that I can remove it (I don’t have a hex key that big).

EDIT: Nevermind on draining the fluid... I just found this advise:
http://www.toyotadiesel.com/forums/showthread.php?t=1926&highlight=steering
Back to top Go down
View user profile
Clive
Hiace Master
Hiace Master
avatar

Number of posts : 1094
Home City : Bristol UK
Model and year : 2003 Range Rover 4.4 goes like a rocket and drinks like Oliver Reed!
Registration date : 2008-11-05

PostSubject: Re: Power Steering issues   Mon Jun 01, 2009 12:09 am

I've just drained it out by the hose, refitted and refilled, a few bubbles and several top ups job done.
Back to top Go down
View user profile
mr freeze
Been here a while
Been here a while


Number of posts : 148
Home City : Sydney South
Model and year : 99 SC 4WD 1KZ-TE
Registration date : 2008-07-14

PostSubject: power steering   Mon Jun 01, 2009 11:18 am

jack up van and undo the hose fitting on the steering rack and turn steering left and right , redo fittings and fill up with turps or prepsol and again left to right and undo fittings and now rack and pump are clean, refill with dexon 3 and should be a fix.
Back to top Go down
View user profile
zoochy
Been here a while
Been here a while
avatar

Number of posts : 148
Home City : Tropical Canada
Model and year : LH107G 1991
Registration date : 2007-01-21

PostSubject: Re: Power Steering issues   Mon Jun 15, 2009 12:10 am

Problem fixed!

I drained and flushed the pump and rack with turpentine then filled it with some “power steering fluid” I had kicking around. Got the air out and went for a test drive and it was worse than before which got me thinking… Perhaps it was the wrong fluid.

Drained it again and filled it with Dextron 3 Automatic Transmission fluid and ta daaa, it works great. I guess not all power steering fluids are equal. Lesson learned.

Thanks again guys.
Back to top Go down
View user profile
zoochy
Been here a while
Been here a while
avatar

Number of posts : 148
Home City : Tropical Canada
Model and year : LH107G 1991
Registration date : 2007-01-21

PostSubject: Re: Power Steering issues   Mon Jun 15, 2009 10:42 pm

Hanging a bucket to catch the power steering fluid.





Undo both to and from lines of the powersteering pump.

Back to top Go down
View user profile
AussieQ
Hiace Master
Hiace Master
avatar

Number of posts : 884
Age : 70
Home City : Hervey Bay Qld
Model and year : 1994 sc
Registration date : 2008-08-15

PostSubject: Re: Power Steering issues   Thu Jun 18, 2009 11:30 am

Good piccies
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Power Steering issues   

Back to top Go down
 
Power Steering issues
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Wanted: Webley Mk. VI & Inglis Hi-Power Pistol... DEWAT/Deactivated
» Spirit Guides & Power Animals
» Nuclear Power and Capitalism
» Browning Hi Power Holster
» Canadian Hi Power..... airsoft

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Mechanical Matters :: GREASE MONKEY !!! (sorry couldnt resist its a BF2142 thing)-
Jump to: