Toyota Hiace Super Custom Owners Forum

Anything Toyota Hiace related
 
HomeHome  PortalPortal  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Speedo Problems

View previous topic View next topic Go down 
AuthorMessage
kylorda
New Member
New Member


Number of posts : 3
Home City : Leeds, England
Registration date : 2009-07-19

PostSubject: Speedo Problems   Thu Aug 06, 2009 8:08 pm

Problem I'm having is that the digital speedo on my super custom seems to have a mind of its' own. I can be doing 50mph one second, then it drops to 0 then up to 120 without me having moved my accelerator foot one bit.

Anyone had the same problems, or know what causes it.

Many thanks

Dave
Back to top Go down
View user profile
maximus
Hiace Master
Hiace Master


Number of posts : 472
Age : 45
Home City : Cheshire
Model and year : 93 2.4 turbo supercustom limited
Registration date : 2007-06-09

PostSubject: Re: Speedo Problems   Fri Aug 07, 2009 11:55 pm

if its in mph then it might have been played with.i think all the imports are in kph.
Back to top Go down
View user profile
mr freeze
Been here a while
Been here a while


Number of posts : 148
Home City : Sydney South
Model and year : 99 SC 4WD 1KZ-TE
Registration date : 2008-07-14

PostSubject: Re: Speedo Problems   Sun Aug 09, 2009 2:05 am

if these digital speedo's have a cable , sounds like it could be broken to me
Back to top Go down
View user profile
kylorda
New Member
New Member


Number of posts : 3
Home City : Leeds, England
Registration date : 2009-07-19

PostSubject: Re: Speedo Problems   Sun Aug 09, 2009 6:10 pm

It was in KPH but it has had a relay fitted to change it to mph.had that checked it is ok. was wondering if there was another relay hidden away somewhere.
Thanks
Dave
Back to top Go down
View user profile
tom
New Member
New Member


Number of posts : 7
Home City : hertfordshire
Registration date : 2011-11-13

PostSubject: Re: Speedo Problems   Sat Jul 21, 2012 10:27 pm

I have a 1993 hiace import and the speedo cable came detached from the gear box resulting in the inner cable disappearing on the motorway. i've replaced the inner cable BUT the speedo now tells me that I'm going 20mph faster than before. Is there some sort of converter/gearing between the gearbox and the speedo cable that may have fallen off at the same time? and if so, where do i get one from? Toyota UK can't help as they don't DO imports and I have drawn a blank everywhere else. Or is the problem in the speedo in the cab which is MPH, I guess it was changed when the van was imported. I'd really appreciate some positive help on this. Thanks.
Back to top Go down
View user profile
chrisandhiace
Hiace Master
Hiace Master


Number of posts : 502
Age : 55
Home City : Preston
Model and year : LH 107 4wd 1992
Registration date : 2008-11-18

PostSubject: Re: Speedo Problems   Sat Jul 21, 2012 11:57 pm

Mine has a gear driven adaptor between the box and cable end.....
A bit like this...a bit of searching and you may find a lower price.....very easy to diy fit
http://www.ncs-systems.com/prod/1218
Back to top Go down
View user profile
tom
New Member
New Member


Number of posts : 7
Home City : hertfordshire
Registration date : 2011-11-13

PostSubject: Re: Speedo Problems   Wed Jul 25, 2012 7:43 am

christine, thankyou so very much for your help. the part is ordered and is hopefully wingings its way to me as i type this message. it's a shame that preston is so far away from watford, 'cos i'd buy you a drink to say thankyou. regards tom x
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Speedo Problems   

Back to top Go down
 
Speedo Problems
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Bank of England warns of problems
» Moltke's tactical problems
» Has 'the Right to Buy' and lack of rent controls caused most of the UK's housing problems?
» Forum causing problems to access to webmail personalized
» The Tale of the Slovakian Speedo by Ivor slipper

Permissions in this forum:You cannot reply to topics in this forum
Toyota Hiace Super Custom Owners Forum  :: Hiace Mechanical Matters :: GREASE MONKEY !!! (sorry couldnt resist its a BF2142 thing) :: Members guides to fixing problems :: Members guides to fixing problems-
Jump to: